WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

#27136 closed defect (bug) (fixed)

Installed plugin and theme search searched html

Reported by: enej Owned by: johnbillion
Milestone: 3.9 Priority: normal
Severity: normal Version: 3.9
Component: Administration Keywords: needs-patch
Focuses: ui Cc:

Description

Currently if you search your installed plugins and type 'strong' it will return plugins that have anything bolded in the description of the plugin.

Attachments (3)

class-wp-plugins-list-table.diff (504 bytes) - added by enej 7 years ago.
patch for the bug…
theme.diff (757 bytes) - added by enej 7 years ago.
Strips out tags from the name, description and authors in javascript.
27136.diff (899 bytes) - added by SergeyBiryukov 7 years ago.
Minor cleanup

Download all attachments as: .zip

Change History (12)

@enej
7 years ago

patch for the bug...

#1 @danielbachhuber
7 years ago

  • Component changed from General to Administration
  • Keywords commit added
  • Milestone changed from Awaiting Review to 3.9

Heh, nice find! Tested and confirmed the fix.

#2 @SergeyBiryukov
7 years ago

This applies to installed themes search as well.

Last edited 7 years ago by SergeyBiryukov (previous) (diff)

#3 @johnbillion
7 years ago

  • Owner set to johnbillion
  • Resolution set to fixed
  • Status changed from new to closed

In 27507:

Avoid searching HTML tags when searching plugins and themes. Fixes #27136. Props enej.

#4 @nacin
7 years ago

FWIW, the themes list table is unused; all of this is handled in JS now.

#5 @SergeyBiryukov
7 years ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

[27507] didn't actually fix this for Themes screen. Looks like WP_Themes_List_Table is unused since [26141].

To reproduce, add <strong>2014</strong> somewhere in a theme description, then search for "strong".

#6 @johnbillion
7 years ago

  • Keywords needs-patch added; commit removed
  • Summary changed from installed plugin search searched html to Installed plugin and theme search searched html

Gah. Guess I got distracted because I was testing #26873 and #27235 at the same time.

@enej
7 years ago

Strips out tags from the name, description and authors in javascript.

#7 @enej
7 years ago

I think the theme.diff file should also fix the javascript part of the theme search.

@SergeyBiryukov
7 years ago

Minor cleanup

#8 @nacin
7 years ago

This would be quite a bit slower, I imagine, and require this to be done with every search. Perhaps we can cache the raw version of these directly in the model.

#9 @samuelsidler
7 years ago

  • Resolution set to fixed
  • Status changed from reopened to closed

We're going to resolve this as fixed for 3.9.

I've spun out the theme search part of this into #27561. If someone wants to take that on, we'll land it early in the 4.0 cycle.

Note: See TracTickets for help on using tickets.