WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

#27143 closed defect (bug) (duplicate)

Product Categories Selection Menu Uncategorized

Reported by: davidfhannes Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.8
Component: Menus Keywords:
Focuses: Cc:

Description

Please refer to this screen shot attached.

http://162.144.54.1/wp-content/uploads/ss_reply_to_Jody_2-16-14.jpg

What is attached is a screen shot of my Toggle Menu, applied via a widget to the sidebar on the site. The Toggle Menu is built under Appearances...Menus.

Note: I still need to build up the bulk of this menu.

Notice that the first group in my toggle menu is Filter by Category. The menu options on here were selected by me from the Product Categories menu under Appearances...Menus.

Unfortunately, now that I have added almost 200 categories, the Product Categories menu is incurring a root level glitch, it is near impossible to select the correct child menu categories and to place them under the parent categories which I have selected prior when building Filter by Categories under for the Toggle Menu.

Example: notice the Category ‘Alvin’ exists FOUR TIMES in the example screen shot under View All. This is not a typo. Alvin is a brand for multiple sub-sub categories. It is a brand that should exist as a product category under the child category of a parent category three levels down the tree. I should be able to clearly identify this child’s parent and grandparent category…I can’t! This is because all four grandchild product categories for Alvin exist under the Root, A-Z, in the Product Categories selection menu. It is a mess.

This isthe problem at hand. Product Categories selection menu is not working as it should and is not showcasing a tiered menu of parent and child categories and it should. There is something amiss.

NOTE: my Category structure tree is just fine if I go to Products...Categories in the dashboard where my parent and child categories were created, the structure is sound.

Please refer to the following screenshot of the dashboard on this page: http://162.144.54.1/wp-content/uploads/ss_product_categories.jpg

It's an accurate depiction of a tree menu.

Please advise.

Change History (1)

#1 @SergeyBiryukov
6 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #18282, #19837, #20351, #24436, and #25262.

Note: See TracTickets for help on using tickets.