WordPress.org

Make WordPress Core

Opened 6 years ago

Last modified 20 months ago

#27511 reopened defect (bug)

Upper "Select All" checkbox for list of plugins to update on update-core.php does not work on first click

Reported by: vanjwilson Owned by:
Milestone: Awaiting Review Priority: normal
Severity: minor Version: 3.8.1
Component: Upgrade/Install Keywords:
Focuses: ui, administration Cc:
PR Number:

Description (last modified by SergeyBiryukov)

(Minor annoyance)

On the admin page:

update-core.php

when there is a list of plugins with Updates Available, the first time you click on the "Select All" checkbox, it does not actually affect any of the checkboxes in the list.

The first time it happened, I just thought it might be a one-time or install-specific occurrence. Then, I had to update a different WordPress install on the same cPanel server, in a different account. In both cases, I went to the equivalent "Select All" checkbox at the bottom of the list, and it worked on the first click.

I then had to do updates on a VPS with a multisite install of Wordpress, and again the upper box did not work at first. However, I kept clicking it, and after about clicking it on, then off, then on again, the upper checkbox started affecting all the checkboxes in the list again.

Change History (7)

#1 @Clorith
6 years ago

  • Severity changed from normal to minor

Hi van,

I've not had this happen my self, what browser and version are you using when you experience this behavior?

#2 @SergeyBiryukov
6 years ago

I can reproduce if I click the checkbox before the page has finished loading. The code that handles the click is in wp-admin/js/common.js, which is loaded in the footer.

Note that the page can take quite a bit of time to load with a lot of plugins on a local install, because a separate request to api.wordpress.org is made for each plugin, see comment:5:ticket:20002.

Last edited 6 years ago by SergeyBiryukov (previous) (diff)

#3 @vanjwilson
6 years ago

@Clorith,

I was using Chrome Version 33.0.1750.152 on Mac OS X 10.8.

I just tried to recreate this issue in Chrome and Firefox 28 on Mac, and could not reproduce it.

I think @SergeyBiryukov may be right--the Updates page may not have been fully loaded before I tried to click the top Select All box. (Having to scroll to get to the bottom Select All would have allowed enough time for page to finish loading, and I would not have seen the "bug" there.

At this point, I'd be happy to mark this as Resolved, unless there's some more documenting that I need to do.

When marking this as Resolved, should I choose "invalid" or "worksforme"?

#4 @chriscct7
4 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

#5 @SergeyBiryukov
2 years ago

#42062 was marked as a duplicate.

#6 @Presskopp
2 years ago

  • Resolution worksforme deleted
  • Status changed from closed to reopened

I experienced this on several 4.8.2 installations lately.

Talking about a solution:
Not sure if this would be feasible, but can we wait until page is loaded completely ( $(document).ready or so ), then check if 'Select all' checkbox has been set (in the time the page was still loading), and if so, mark all the plugins (again)?

#7 @SergeyBiryukov
20 months ago

  • Description modified (diff)
  • Milestone set to Awaiting Review
Note: See TracTickets for help on using tickets.