WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

#28031 closed defect (bug) (duplicate)

Broken category taxonomy on menu builder page

Reported by: mihais Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.9
Component: Taxonomy Keywords:
Focuses: Cc:

Description

Where: menu builder -> categories -> all
When: the taxonomy is breaking after I create more than 50 categories.
How to reproduce:

  • have the following tree of 51 categories (will trigger pagination on Menus > Categories - 50 items per page):

A

  • A01
  • A02
  • A03
  • A04
  • A05
  • A06
  • A07
  • A08
  • A09
  • A10
  • A11-

B

  • B01
  • B02
  • B03
  • B04
  • B05
  • B06
  • B07
  • B08
  • B09
  • B10
  • B11-

C

  • C01
  • C02
  • C03
  • C04
  • C05
  • C06
  • C07
  • C08
  • C09
  • C10
  • C11

D

  • D01
  • D02
  • D03
  • D04
  • D05
  • D06
  • D07
  • D08
  • D09
  • D10
  • D11
  • D12

L
P


  • category P will be on the second page
  • adding a new ROOT category greater than L (M, N ....) will not affect the category tree - the new category will be on the second page.
  • adding a new ROOT category between D and L ( E,F, G, H, I, J, K) will push L on the second page and the new category will be the last one on the first page.
  • adding any other subcategory in the ROOT categories A, B, C, D or a new ROOT category (ex: A10000) will let L as the last element on the first page and the last element of the last subcategory (in our case D12) will be pushed on the second page.
  • conclusion: the categories tree will break so that the last element on the first page is a ROOT category.

Change History (1)

#1 @SergeyBiryukov
4 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #18282 (also #19837, #20351, #23286, #24436, #25262, and #27143).

Note: See TracTickets for help on using tickets.