WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#33650 closed defect (bug) (duplicate)

#a11y-headings - Sub headings in Admin Panel Should be h2 instead of h3

Reported by: mrahmadawais Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.3
Component: Administration Keywords: has-patch dev-feedback
Focuses: accessibility Cc:

Description (last modified by afercia)

I've created this ticket to address all the headings inside admin panel, which should now be h2 headings instead of h3, since after the main heading was converted from h2 to h1.

#a11y-headings

Attachments (1)

33650.patch (2.9 KB) - added by mrahmadawais 5 years ago.
Converts h3 to h2 for options-media.php, options-writing.php and options-discussion.php

Download all attachments as: .zip

Change History (15)

@mrahmadawais
5 years ago

Converts h3 to h2 for options-media.php, options-writing.php and options-discussion.php

#1 @mrahmadawais
5 years ago

  • Keywords has-patch dev-feedback added

#2 @Cheffheid
5 years ago

I would hereby like to invite you to the accessibility channel on Slack. If you're not on Slack yet, please go to this page: https://make.wordpress.org/chat/

We've already been creating tickets to handle this per page to keep patches small and easy to test, which makes a larger ticket redundant and confusing. Please also take a look here, where you can find a link to a list of tickets that are still open for this issue: https://make.wordpress.org/accessibility/handbook/current-projects/heading-semantics-in-the-admin/

#3 @mrahmadawais
5 years ago

@Cheffheid
I thought one ticket for all such changes would be more helpful. Should I create different smaller tickets for similar issue but in different files?

This ticket was mentioned in Slack in #accessibility by mrahmadawais. View the logs.


5 years ago

#5 @Cheffheid
5 years ago

Most of the smaller ones have already been created and some have already been fixed as well. :)

Post Meta Boxes: #33557
Dashboard: #33558
Menus page: #33603
Widgets page: #33604
Add New User page: #33605
Your Profile page: #33606
Export page: #33608
Discussion Settings: #33609
Media Settings: #33610
Screen Options: #33646

I've not yet gone through the multisite specific pages though, so feel free to create tickets for those.

#6 @chriscct7
5 years ago

Some of these headings that deal with settings are slated for removal in 4.4 in #32396

#7 @Cheffheid
5 years ago

@chriscct7: I see that the post by email stuff is getting removed, which I see you've already noted in the ticket for that page (#33651). We can go ahead and close that one, I feel.

Any decision on the Avatar(#33609) and Image Size(#33610) settings?

#8 @chriscct7
5 years ago

The outlook is avatars will be axed, and the image sizes will be staying at least for 4.4 at the moment. That could change though

#9 @SergeyBiryukov
5 years ago

  • Milestone changed from Awaiting Review to 4.4

#10 @afercia
5 years ago

  • Description modified (diff)

This ticket was mentioned in Slack in #accessibility by afercia. View the logs.


5 years ago

#12 follow-up: @afercia
5 years ago

  • Milestone 4.4 deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #33557.

The headings covered in this tickets have already their own tickets and as agreed in the accessibility team we'd prefer to proceed screen by screen (or file by file). Going to close this one as duplicate, that's not to say it was invalid, all the things here make perfectly sense. Thanks very much @mrahmadawais !

#13 in reply to: ↑ 12 @mrahmadawais
5 years ago

Replying to afercia:

Duplicate of #33557.

The headings covered in this tickets have already their own tickets and as agreed in the accessibility team we'd prefer to proceed screen by screen (or file by file). Going to close this one as duplicate, that's not to say it was invalid, all the things here make perfectly sense. Thanks very much @mrahmadawais !

Thank @afercia for the props. I got the file by file thing after our discussion in Slack. Have already created separate tickets and submitted the patches. It makes sense to close this ticket now.

This ticket was mentioned in Slack in #accessibility by mrahmadawais. View the logs.


5 years ago

Note: See TracTickets for help on using tickets.