WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#37045 closed defect (bug) (duplicate)

Hierarchical Tree of Hierarchical Taxonomies is wrong after save in the Meta Box

Reported by: bedas Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.6
Component: Taxonomy Keywords:
Focuses: administration Cc:

Description

  1. Install WordPress
  1. Create some Terms in the native Categories:
- Parent Term
-- Child of Parent Term
-- Child-two of Parent Term
  1. Save a Post with:
- Parent Term
-- Child of Parent Term

See that the order of the Checkboxes is wrong after save:

-- Child-two of Parent Term

should be listed below

- Parent Term

even if unchecked

Attachments (2)

After Save Post.png (43.6 KB) - added by bedas 4 years ago.
After saving the Post the unchecked Child term is out of order
Before Save Post.png (42.4 KB) - added by bedas 4 years ago.
Before save the post, the order is correct

Download all attachments as: .zip

Change History (4)

@bedas
4 years ago

After saving the Post the unchecked Child term is out of order

@bedas
4 years ago

Before save the post, the order is correct

#1 @knutsp
4 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

Quoting @SergeyBiryukov from #30721

Duplicate of #10982, #14723, #14916, #16475, #17135, #17317, #17835, #19880, #20160, #21544, #21127, #29871.

This is intentional, see #10982. A filter was introduced in #20054, allowing plugins to change that behaviour.

This plugin implements the change: https://wordpress.org/plugins/category-checklist-tree/.

#2 @SergeyBiryukov
4 years ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.