Make WordPress Core

Opened 12 months ago

Closed 8 months ago

#58832 closed task (blessed) (fixed)

Bump default theme versions for WordPress 6.4

Reported by: mukesh27's profile mukesh27 Owned by: desrosj's profile desrosj
Milestone: 6.4 Priority: normal
Severity: normal Version:
Component: Bundled Theme Keywords: has-patch commit dev-reviewed
Focuses: Cc:

Description

All bundled themes from 2010 to 2023 will need a version bump for the 6.4 release.

Previously:
#57857 - 6.3
#57689 - 6.2
#56450 - 6.1
#55754 - 6.0
#54783 - 5.9
#53277 - 5.8
#52704 - 5.7
#51919 - 5.6
#50889 - 5.5
#49743 - 5.4

Change History (25)

This ticket was mentioned in PR #4961 on WordPress/wordpress-develop by JessicaGosselin.


12 months ago
#1

  • Keywords has-patch added; needs-patch removed

Bump default theme versions for WordPress 6.4

Trac ticket: #58832

#2 @sabernhardt
9 months ago

#59642 was marked as a duplicate.

This ticket was mentioned in PR #5505 on WordPress/wordpress-develop by @kafleg.


9 months ago
#3

Update version, tested upto, changelog and CSS version
Core ticket: https://core.trac.wordpress.org/ticket/58832

@kafleg commented on PR #5505:


9 months ago
#4

@sabernhardt I found small versioning issue in 2019 theme.

The current version of theme in org is 2.5 but I found that the version 2.6 is already released according to readme file and mentioned version, https://codex.wordpress.org/Twenty_Nineteen_Theme_Changelog#Version_2.6

Would you please give a look on it?

@sabernhardt commented on PR #5505:


9 months ago
#5

All 13 themes were updated in August. However, half of them are a version behind that at wordpress.org/themes.

Also note that Twenty Twenty _might_ still have a version 2.4 this month and then 2.5 with the other themes in November (Trac 59576). The special effort of a separate update becomes less valuable each day, though.

@kafleg commented on PR #5505:


9 months ago
#6

All 13 themes were updated in August. However, half of them are a version behind that at wordpress.org/themes.

Also note that Twenty Twenty _might_ still have a version 2.4 this month and then 2.5 with the other themes in November (Trac 59576). The special effort of a separate update becomes less valuable each day, though.

What can I do in this case? Can i update the theme version based on the trunk version?

@sabernhardt commented on PR #5505:


9 months ago
#7

@desrosj should be involved in this conversation too. My advice would be to continue updating the version according to trunk.

I would like to know whether Twenty Twenty will have a separate version to fix the iframe editor background color (which was backported to 6.3). If we delay the change three more weeks instead, I could close 59576 as a duplicate of 58832 and change the milestone on 59086 to 6.4. My patch for Twenty Twenty does not (yet) update the "Tested up to" version, but that might be almost as appropriate if released this week as it would be November 7.

@desrosj commented on PR #5505:


9 months ago
#8

Thanks all for working on this!

I've gone back and tried to find a reason why those themes were not uploaded on 6.3 release day and I couldn't find any. I have gone back and uploaded the updates for all of those that were missing in the state that they were on release day. This includes Twenty Twenty without the iframe changes.

I think it's best to just include the iframe change in 2 weeks with the WP 6.4 coordinated release, which will now be 2.4.

I still need to give a true review to this PR, but wanted to update my progress so far. Will circle back in the next 48 hours to do that, though I think there may be a few updates that need to be added for Twenty Twenty now as well.

#9 @sabernhardt
9 months ago

#59576 was marked as a duplicate.

This ticket was mentioned in PR #5601 on WordPress/wordpress-develop by @sabernhardt.


9 months ago
#10

Twenty Ten: 4.0
Twenty Eleven: 4.5
Twenty Twelve: 4.1
Twenty Thirteen: 4.0
Twenty Fourteen: 3.8
Twenty Fifteen: 3.6
Twenty Sixteen: 3.1
Twenty Seventeen: 3.4
Twenty Nineteen: 2.7
Twenty Twenty: 2.4
Twenty Twenty-One: 2.0
Twenty Twenty-Two: 1.6
Twenty Twenty-Three: 1.3

Updated version strings:

  • 20231107 for main stylesheet in header.php: Twenty Ten and Twenty Eleven
  • 20231107 for main stylesheet in functions.php: Twenty Twelve to Twenty Seventeen
  • 20231016 for blocks.css in functions.php: Twenty Thirteen and Twenty Sixteen (r56940)

Trac 58832

@sabernhardt commented on PR #5505:


9 months ago
#11

I made a new PR 5601 that includes Twenty Nineteen to Twenty Twenty-Three, plus it corrects the changelog link for Twenty Twenty-Four.

#12 @sabernhardt
9 months ago

I also added drafts for the changelog page updates in the documentation tracker #1275.

#13 @huzaifaalmesbah
9 months ago

Looks good. I noticed that now the TT4 changelog link is not working. I think the article is not published.

#14 @sabernhardt
9 months ago

Yes, the Twenty Twenty-Four changelog article is not published yet (thanks for checking the link).

Both the Twenty Twenty-Two readme and Twenty Twenty-Three readme files had links in their initial releases. However, replacing the link with "Initial release" (for now) might be another option, as the Twenty Nineteen readme and Twenty Twenty-One readme files had that at first.

#15 @desrosj
9 months ago

  • Owner set to desrosj
  • Status changed from new to reviewing

This ticket was mentioned in Slack in #core by jorbin. View the logs.


9 months ago

#17 @rajinsharwar
8 months ago

LGTM, I tried to match all the files that were changed for 6.2, and 6.3, and it doesn't look like any file was missed. But, though the links of Twenty Twenty-One and Twenty Twenty-Three's changelog are working, the new version section isn't there yet. Will that be there immediately with the release of 6.4 @sabernhardt?

#18 @sabernhardt
8 months ago

The link for Twenty Twenty-Four will be corrected separately (#59812).

This ticket was mentioned in Slack in #core by sabernhardt. View the logs.


8 months ago

#20 @desrosj
8 months ago

  • Keywords commit added

#21 @desrosj
8 months ago

  • Resolution set to fixed
  • Status changed from reviewing to closed

In 57069:

Bundled Themes: Bump versions for WP 6.4 releases.

Since every default theme was updated during the 6.4 release cycle, this bumps the version of each one.

Twenty Ten: 4.0
Twenty Eleven: 4.5
Twenty Twelve: 4.1
Twenty Thirteen: 4.0
Twenty Fourteen: 3.8
Twenty Fifteen: 3.6
Twenty Sixteen: 3.1
Twenty Seventeen: 3.4
Twenty Nineteen: 2.7
Twenty Twenty: 2.4
Twenty Twenty-One: 2.0
Twenty Twenty-Two: 1.6
Twenty Twenty-Three: 1.3

Props sabernhardt, rajinsharwar, mukesh27.
Fixes #58832.

#23 @desrosj
8 months ago

  • Keywords dev-feedback added
  • Resolution fixed deleted
  • Status changed from closed to reopened

Reopening for second committer review and backport.

#24 @hellofromTonya
8 months ago

  • Keywords dev-reviewed added; dev-feedback removed

[57069] LGTM for backport to the 6.4 branch.

#25 @desrosj
8 months ago

  • Resolution set to fixed
  • Status changed from reopened to closed

In 57072:

Bundled Themes: Bump versions for WP 6.4 releases.

Since every default theme was updated during the 6.4 release cycle, this bumps the version of each one.

Twenty Ten: 4.0
Twenty Eleven: 4.5
Twenty Twelve: 4.1
Twenty Thirteen: 4.0
Twenty Fourteen: 3.8
Twenty Fifteen: 3.6
Twenty Sixteen: 3.1
Twenty Seventeen: 3.4
Twenty Nineteen: 2.7
Twenty Twenty: 2.4
Twenty Twenty-One: 2.0
Twenty Twenty-Two: 1.6
Twenty Twenty-Three: 1.3

Reviewed by hellofromTonya.
Merges [57069] to the 6.4 branch.

Props sabernhardt, rajinsharwar, mukesh27.
Fixes #58832.

Note: See TracTickets for help on using tickets.