WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#45681 closed task (blessed) (fixed)

Bundled Themes: Bump version numbers and update changelogs for 5.0.2 release

Reported by: laurelfulford Owned by: laurelfulford
Milestone: 5.0.2 Priority: normal
Severity: normal Version: 5.0.1
Component: Bundled Theme Keywords: has-patch commit
Focuses: Cc:

Description (last modified by laurelfulford)

Since 5.0.2 will ship with some fixes to the default theme block editor support that was added in 5.0, let's add a Task to bump each theme’s version number and update each changelog.

Related tickets:

Note: Twenty Nineteen is still on GitHub, so I've listed revisions for changes rather than tickets, just to make it easier to see what's changed in 5.0.2 from #45424.

Handbook page: https://make.wordpress.org/core/handbook/about/release-cycle/update-bundled-themes/

Previous related tickets for reference: 5.0: #45167 4.9.5 #43572

Attachments (3)

45681.patch (20.5 KB) - added by laurelfulford 3 years ago.
45681.1.patch (20.9 KB) - added by laurelfulford 3 years ago.
Bumping to correct WP version -- 5.0.2 -- and re-adding line break at end of Twenty Nineteen's readme.
45681.2.patch (20.8 KB) - added by laurelfulford 3 years ago.
One more run at this, to get the correct 'Tested up to version' to 'WordPress 5.0'

Download all attachments as: .zip

Change History (12)

#1 @laurelfulford
3 years ago

  • Description modified (diff)

@laurelfulford
3 years ago

#2 @laurelfulford
3 years ago

  • Keywords has-patch needs-testing added; needs-patch removed

#3 @laurelfulford
3 years ago

I also created an issue in the Twenty Nineteen GitHub repo to update the same files, to make sure Trac doesn't get ahead of that version of the theme:

https://github.com/WordPress/twentynineteen/issues/744

#4 @davidakennedy
3 years ago

  • Keywords commit added; needs-testing removed

The patch looks good, @laurelfulford. Feel free to commit.

This ticket was mentioned in Slack in #core-committers by laurelfulford. View the logs.


3 years ago

@laurelfulford
3 years ago

Bumping to correct WP version -- 5.0.2 -- and re-adding line break at end of Twenty Nineteen's readme.

@laurelfulford
3 years ago

One more run at this, to get the correct 'Tested up to version' to 'WordPress 5.0'

#6 @peterwilsoncc
3 years ago

LGTM 👍

#7 @laurelfulford
3 years ago

  • Resolution set to fixed
  • Status changed from assigned to closed

In 44322:

Default Themes: Bump the version numbers and release dates.

Update the theme versions and release dates for the default themes, in time for WordPress 5.0.2.

The POT files for Twenty Ten and Twenty Eleven have also been updated.

Fixes #45681.

#8 @laurelfulford
3 years ago

In 44323:

Default Themes: Bump the version numbers and release dates.

Update the theme versions and release dates for the default themes, in time for WordPress 5.0.2.

The POT files for Twenty Ten and Eleven have also been updated.

Merges [44322] into the 5.0 branch.
Fixes #45681.

Note: See TracTickets for help on using tickets.